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I.A. Summary of BrainMaker ROI Drawing Analysis Tool:
BrainMaker lets you draw ROIs on 3 orthogonal slices from an image volume. A ROI drawn in one
view is updated in the other two orthogonal views. All functions and display aspects work equally
well in all views. The individual ROIs are combined into a single Volume-of-Interest or VOI.

You can then extract regional data from multiple slices of a coregistered image volume to obtain
information about an VOI. You can also obtain morphometric information about individual VOIs.

The entire program is controlled through a series of Graphical User Interfaces (GUIs) via the
mouse. Little if any command-line typing is required. There are also facilities for semi-automated
region searches, image smoothing, tissue segmentation, and numerous display options.



I.B. Introduction:
The philosophy underlying BrainMaker is that the bulk of the work in image-analysis involves
defining regions, so it should be as easy and enjoyable as possible. BrainMaker  seeks to make the
process of defining regions rapid and accurate, and also attempts to ensure that the regions, once
defined, can be stored and used later with confidence.

BrainMaker and its subroutines let you place Regions of Interest (ROIs) on a MRI image volume,
save the ROIs as a mask, and apply the mask(s) to another image volume (e.g. PET) which has
been previously coregistered to the MRI volume. The MRI images act as a reference for creating
accurate delineations of 2D (slice) or 3D (volumetric) anatomical structures. The ROIs from
multiple slices are combined to create a Volume-of-Interest (VOI) which is treated as a single
entity.

The VOIs are stored in an image-volume which has the identical dimensions as the reference (MRI)
volume. This can require a large amount of storage space, but the possibility of error in extracting
data for a masked area is minimized. In addition, this format facilitates treating data from multiple
slices as a cohesive Volume-of-Interest, so values for all pixels within an entire anatomical
structure are weighted equally. Furthermore, this file format is extremely portable; it is easy to
figure out what the VOI describes even without access to SPAMALIZE.

Coregistering related image volumes (e.g. PET) to the reference MRI volume permits subsequent
extraction of data for each ROI or VOI. This program does NOT perform coregistration. The image
volumes should be coregistered PRIOR to using this program. You may use any coregistration
method you like, but it is up to you to verify the validity of the coregistration for each data set.
Some tools are provided in BrainMaker and BrainSqueezer to assist in this.

This manual introduces you to all of the BrainMaker’s menus and tools, and provides illustrated
step-by-step examples of common analysis strategies.

I.C. Conventions:
Menu items such as button labels and pull-down menus are indicated by Arial Font, and are usually
in quotation marks.

Pull-down or nested menu actions are indicated by a series of arrows, e.g.
“Analysis -> BrainMaker -> Segmentation”
indicates you should select “Analysis” from the current menu, then select “BrainMaker” from the
pull-down mwnu that appears when you select “Analysis”, then select “Segmentation” from the
resulting menu.

Items in Times-Roman font but in quotations refer to descriptions of menus, buttons, icons, etc.
where there is not an actual text-button to press.

The term “ROI” generally refers to a a flat 2D image mask, usually visible on one ar more current
views. The ROIs are slices of the working Volume-of-Interest (VOI). The term “VOI” refers to a
3D volumetric mask. Specific slices of the VOI can be viewed as 2D ROIs. Changes to a ROI are
automatically incorporated into the VOI so each ROI view always shows the status of the VOI.



II. Getting Started
This section gives an overview of the steps required to start using BrainMaker. Refer to the
subesequent sections for specific details. If you are unfamiliar with BrainMaker, you should read
all of  the "Getting Started" sections.

II.A. Getting Started: Overview
0) Enter BrainMaker from the SPAMALIZE main menu: “Analysis -> BrainMaker (ROIs)”.
1) Read in a reference file. Typically this will be a MRI image volume.
    Most buttons are de-activated until a valid MRI has been loaded.
2) Read in a coregistered image you are interested in (typically a PET file).
    This step is not required, but can be helpful for comparison purposes.
3) Most drawing actions are controlled from BrainMaker’s Icon Menu.
    Pass the cursor over a button to obtain a brief description of its use
    in the Draw Menu's message window. Click on a button to use it.
4) View different axial/coronal/sagittal slices by selecting and dragging the slider labeled
     "Axial Plane #" (or Coronal, Sagittal), or by clicking on the nearby arrow buttons.
5) Switch to the axial, coronal or sagittal view being currently active by clicking the
    “Axial”, "Coronal" or "Sagittal" icon buttons.
6) Change location by clicking with the middle mouse button on any image.
     The other orthogonal views will automatically go to the new location.
7) Draw/Erase ROIs with the left mouse button, which also changes the orthogonal views
     to show the current location.
8) The right mouse button pops up a menu of shortcuts.
9) Obtain access to optional parameters by clicking "Display Options" button,
     which pops up the "BrainMaker Display Parameters" menu if it is not present.
10) The "Anatomy" button pops up a menu which allows you to specify anatomic structures,
    read or create a ROI mask volume, and provides tools for saving, deleting,
    and viewing masks.
11) Click on the "Segmentation" button to get a large menu for segmenting the MRI
     imge volume, using a histogram of the data. You can also smooth, find edges,
     specify ROI drawing for specific tissue types, etc. from this menu.
12) There are many canned analysis procedures available in the "Analysis" menu.
      For example, extract values from PET data for anatomical structure by clicking
      on the Analysis menu item "Apply ROI".
13) Select "ROI stats" to see parameters for the current mask and location.
14) Use the “Color Table” buttons in the BrainMaker main menu or other sub-menus to alter
       the color of the images. Do not use the “Color Table” button in SPAMALIZE’s main menu.



II.B. Getting Started: File Info
All image files used by BrainMaker must be in ANALYZE format (defined by Mayo Clinic,
Rochester, MN, website http://www.mayo.edu/bir/), which consists of a block of data accompanied
by a small header file. You should be familiar with this format, or have a friendly relationship with
someone who is. There are many programs in other parts of SPAMALIZE to deal with reading,
writing, massaging, and converting to the ANALYZE format.

ANALYZE data are stored so the first point is the subject’s lower, back, right-hand side (inferior,
posterior, right).  This means that the first plane in a data set is usually the bottom-most. This also
means that ANALYZE images are displayed according to the radiological convention, where the
subject’s right-hand side is displayed on the left-hand side of your screen (Right-is-Left). Some
programs (like SPM) will automatically swap the right- and left-hand sides to obtain a Neurological
view (Right-is-Right). Results from different programs are compatible as long as:
  a) no swapping occurs, or
  b) the data are unswapped prior to writing to a file.

The bottom of the brain is usually the first image, the top of the brain is usually the last image. For
non-standard ANALYZE files the orientation may be different.

YOU MUST CHECK THIS ASSUMPTION FOR ALL OF YOUR DATA!
Note that in the LfAN, our MRI data are NOT in the standard ANALYZE format. To date, we have
not changed the orientation if the data are being used for morphometric (structural) measurement. If
th data will be fed into a subsequent analysis program (like SPM), we do swap the orientation to
conform to the needs/assumptions of that program.

The file format can be any of the following types:
  BYTE 8-bit unsigned integer
  INT 16-bit signed integer
  LONG 32-bit signed integer
  FLOAT 32-bit floating point
  DOUBLE 64-bit floating point
This information is contained in the “*.hdr” file accompanying every image “*.img” file.The
convention is that the image data file ends in ".img" and the header file ends in ".hdr".  These files
must be in the same directory.  When specifying a file, generally you need to supply the full
directory path as well as the file name. The image volume should contain three (3) dimensions: X,
Y, and Z.  It is possible to read a 2D or 4D volume, but many of the analysis and display programs
will balk.

Most problems with reading ANALYZE files are due to incorrect values in the *.hdr file. If you
need to view and/or edit the *.hdr file, use the utility found in SPAMLIZE’s main menu:
“File -> Fix headers -> ANALYZE Format”, which has its own “Help” menu.

The user should have read-permission for the original MRI (and PET) images, and write-
permission for the directory where any output files (like the VOI mask) will go. The default
location for most data output in SPAMALIZE is to a directory on a large disk that all users have
write-permision for. At the LfAN, this is “/scratch/”. However, it is useful to have write-permission
to the disk where your MRI files are, since the name of the output VOI mask file is based on the



full name (including the path) of the MRI file. The output VOI mask file(s) are written to the
directory where the original image volume lives if you have write-permission, otherwise it goes to
the default temporary directory. Check with your local SPAMALIZE administrator if you have
trouble writing a file.

If you create a VOI (mask) image and want to save it, you will find it most convenient to write it to
the MRI directory.  If you do not have write-permission to the directory containing the MRI image,
you should copy the MRI data file (.img) and the MRI .hdr file to a directory which you own and
can write to. At the LfAN, most VOIs go into specific study directories; if you cannot write to the
correct directory, talk to John or Terry.

If you apply a ROI to a coregistered (PET) volume, the output results generally are written to the
PET directory. Many analysis routines allow you to specify a file name and location. In all events,
you must have write-permission for the desired output directory. SPAMALIZE usually tries to
write to the temporary directory (“/scratch/”) if it cannot write to the first choice, but this may not
always happen. Best bet: work in a directory where you can read and write. And back up often!

II.C. Getting Started: Read MRI Reference
The first step is to read in a reference image volume which is in ANALYZE-format.  Typically this
is a MRI file, but it can be any ANALYZE-formatted image volume (PET, CT, ROImask, etc.).
The contents of the file are (mostly) irrelevant. For simple ROI drawing operations, the images
merely act as “wallpaper” behind your ROIs. For more sophisticated operations, like connected-
pixel searches or histogram thresholding, the image data contents are actually used.

To read a MRI volume, click the flashing file-folder icon next to the MRI File text box of
BrainMaker’s small main menu. The icon flashes "Pick Me!". Use the browser to select an
ANALYZE image. A good sample data set is contained in the SPAMALIZE data directory.
At the LfAN, this is:
/local/progs/spamalize/data/nT1.img
/local/progs/spamalize/data/nT1.hdr



\\PSYPHW\DATA\local\progs\dev\spamalize\src\help\help_BrainMaker_app_fn.doc
Upon loading, the current location is the pixel designated in the header as the "origin", or if none is
specified, the center of the volume. The current location is very important in SPAMALIZE. It
defines the intersection of the 3 current orthogonal planes (axial, coronal, sagittal) which are
displayed. Moving the current location changes the displayed images. The current location also
designates the pixel which will be included/erased from the ROI mask you are working on.

The images below illustrate the concept of the current location, which is at the intersection of the
yellow crosshairs. The same pixel is at this intersection in the axial, coronal, and sagittal views, as
well as in the composite 3D image (created with BrainSpinner) at the lower right. Since these
images have just been loaded, the current point is the origin specified in the *.hdr file, which in this
case is the Anterior Commisure.



II.D. Getting Started: Read PET Reference
You may load an image volume which has been coregistered to the MRI reference volume.
Typically this is a PET volume from which you wish to extract ROI information. The PET data is
not actually used for anything during the process of creating the ROI masks. There is no need to
load the PET data, but it can be helpful in some cases to compare the physiological and structural
information, or to asses the validity of a coregistration (actually, BrainSqueezer is btter suited for
this last item).

Click the file-folder icon next to the "PET File" text box to browse for and load the PET data.

The PET image (if loaded) is displayed in the "Adjunct" display window.  If you choose not to load
a PET image (most folks don’t), the MRI and/or mask will be displayed in this window instead.
The adjunct window is useful if you load a PET image, but can lead to the appearance of
redundancy otherwise since another view of the MRI will appear if no PET data are loaded.

The PET data must be in an ANALYZE-formatted file.  If the PET file does not have the same
dimensions as the reference (MRI) data, SPAMALIZE will refuse to read in the PET file.  The
image displayed in the Adjunct window is determined by the "Orientation" icons. To view a
coronal slice in the Adjunct window, click on the "Coronal" icon. To make the Adjunct window
disappear (and speed up display slightly in other windows), click on its "Quit" button. It will only
re-appear when you click the "Show Adjunct View" icon.

Clicking in the Adjunct view will cause a connected-pixel search to be performed starting in that
location, but based on the PET image.

II.E. Getting Started: Draw ROI Intro
In BrainMaker, when you draw a Region-of-Interest (ROI) you are actually creating a binary mask
of a region. Conceptually, all pixels within the ROI have a value of "1" and all other pixels in the
mask-image have a value of zero. It is called a mask because if you multiply a mask with the
underlying image on a pixel-by-pixel basis, only the masked image pixels are visible; all non-
masked pixels are set to 0.

The image to the far left shows a
MRI image with a mask of the entire
brain overlaid in red. If this mask is
multiplied by the brain, the resulting
image on the near left is produced.
The image values within the mask
are unchanged, but the values
outside of the mask have been set to
zero. This is a common approach for
extracting ROI information from e.g.
PET data: multiply the mask by the
image data, then calculate the
average data value within the ROI.



There are many ways to draw a ROI in BrainMaker:
  1) Draw around the edge of a structure using the ROI freehand tool;
  2) Use a shape-tool (circle, rectangle, etc.) to draw a specific shape;
  3) Add/remove a pixel (or group of pixels) using the pencil/eraser tool;
  4) Find similarly-valued pixels spatially connected to the current pixel;
  5) Fill interior regions of a partially drawn ROI;
  6) Use the tissue segmentation information to limit a ROI to a range of values.
The mask produced by any of these approaches is treated identically once it  is created. Also, there
is no preferred view; the axial, coronal, and sagittal views are treated identically. Note that all
changes are cumulative; you are editing a single plane, but you are really adding (or deleting)
pixels to an underlying mask image-volume.

Editing options are explained in more detail in the “Icon Menu” section below. Drawing a structure
freehand is generally the most reliable and time-consuming approach. It is the only option if the
structure does not have crisp edges or if there is a small path that allows the search to "leak" into
unwanted areas, which precludes the use of automated search tools. Select the "Draw ROI
(freehand)" icon. Click the left mouse button in a draw-window to start the ROI, and release the
button to close the ROI. Slow, deliberate mouse clicks will be rewarded; fast, spastic clicks will
confuse BrainMaker.

You can edit individual pixels, or groups of pixels, by using the pencil and eraser icons. Select a
cursor size by clicking on one of the "Cursor size..." icons. The "Smart Add/Remove" feature will
add to the mask if the current location is NOT in the mask, and will delete from the mask if the
current location is in the mask. Editing individual pixels is extremely useful, but will "hiccup"
frequently: the program will not notice that you pressed a button about 10% of the time. This is
frustrating, and happens because the program is processing a huge amount of data and ignores
button events until it is ready to start a new process.

To save a VOI to a file, you must open the “Anatomy” menu. There is a separate help menu that
explains this in detail. In brief, you need to put the current working mask into the reference mask
group-volume, then save the entire group volume (which may contain several individual VOIs) to a
file.



III. Menu Descriptions
This section briefly describes features available through various sub-menus. More detailed
descriptions are available in subsequent sections of this manual. To access these menus, select
the designated button from BrainMaker’s main menu.

“Display Options”: Pops up a separate window with numerous options and parameters. This menu
is visible when BrainMaker is started, but can be dismissed. In addition to display options, the
current location is shown here. You can type a number into any of the location test-boxes to go
to that location.

“Anatomy”: Pops up a separate menu that allows you to specify anatomical regions. This menu is
where you load an existing mask or create a new one, save or delete a ROI from the mask, name
the ROI, save the mask volume to a file, and examine ROIs. This menu has its own "Help" menu.
This is not really a sub-menu, but rather is just as important as the main BrainMaker menu.

“Segmentation”: Pops up a menu for image segemntation (tissue classification). The segmentation
is based on a histogram of the MRI data. You can select certain tissue values and types that you
want to automatically include or exclude from your ROIs. There are further sub-menus to
smooth the MRI volume, find edges, segment the whole brain, etc.

“ROI stats”: Pops up a separate menu that displays statistical information about  the currently
loaded image volumes (MRI, PET, Mask) as well as for the current ROI and VOI.

“Analysis”: Produces a pull-down menu with a number of analysis options. The underlying
programs tend to have been written for a single purpose. All of these programs have worked (and
worked well) in the past. If you experience difficulties, notify Terry Oakes; it will probably take
only a minor tweak to fix things.

“Color Table”: Lets you select from over 40 different color tables to color the MRI image. You
should only click on the buttons in the BrainMaker main menu or other sub-menus to alter the
color of the images. Do not use the “Color Table” button in SPAMALIZE’s main menu.

“Current Directory”: Produces a pop-up menu with the most recent 5 menus you loaded data from,
as well as 10 popular directories where data tend to be stored. This is a very handy shortcut
feature.

“Help”: Produces a pull-down menu with a number of Help topics. The help you get by clicking
on this button is not as helpful or complete as the web-based help, located at:

http://psyphz.psych.wisc.edu/~oakes/spam/spam_frames.htm

“Quit”: Quits from ROI analysis tool, deleting the main window and all sub-windows. If you quit,
you will have to start all over again by loading in new images. You will lose any data not
explicitly saved to a file. If you have an unsaved ROI mask, BrainMaker should prompt you to
save it before letting you quit. Quitting is a good way to start over; however, SPAMALIZE keeps
the MRI volume in memory, and BrainMaker will re-load the MRI volume if you re-enter it
without quitting from SPAMALIZE. This can be a handy way to use other SPAMALIZE
modules to examine the MRI data.



III.A. Icon Menu:
Following is a description of each of the icons in the “Icon Menu”, which controls most aspects
of editing a ROI. Depending on the color-table in effect when you start BrainMaker, the colors of
the icons may be different than shown below. The icon menu is similar to the picture below. You
are not allowed to dismiss this menu- it must always be present when BrainMaker is running. A
brief description of the function of each icon is shown in the bottom-left text box when the
cursor is passed over any of the icons. Clicking an icon causes the indicated action to take place.

Edit (Add/Erase) individual pixels:
Draw/Add individual pixels. Click with left mouse button to add a single pixel. Press and
drag to add a series of connected pixels or to fill in a region. The number of pixels added at

a time is controlled by the “Cursor size” icons below. A black frame appears around the icon
when you are in Draw/Add mode.

Erase individual pixels. Click with left mouse button to erase a single pixel. Press and drag
to erase a series of connected pixels or to delete a region. The number of pixels added at a

time is controlled by the “Cursor size” icons below. A black frame appears around the icon when
you are in Erase mode.

Smart Draw/Erase. Adds to the mask if the current location is not in the mask, and deletes
from the mask if the current location is in the mask. This is handy for editing an existing

edge, where you want to add some pixels and erase others. Click with left mouse button to
add/erase a single pixel. Press and drag to add/erase a series of pixels. The number of pixels
added at a time is controlled by the “Cursor size” icons below. A black frame appears around the
icon when you are in Erase mode.

Cursor Size: Small. The draw/erase operations will only affect a single pixel at a time.

Cursor Size: Medium. The draw/erase operations will affect a 3x3 square region.

Cursor Size: Large. The draw/erase operations will affect a 9x9 square region. On a
unix/linux platform, the size and shape of the cursor will change to approximate the active

region size. If you are in Edit (draw or erase) mode, the size of the cursor will be indicated by a
black frame around the corresponding icon.



Draw Freeform ROIs:
Draw Freeform. Press the left mouse button to begin drawing a ROI. Hold it down and drag

to define the ROI, and release to end or close the ROI. A black frame appears around the icon
when you are in Draw Freeform mode, while frames around other edit and draw icons will
become white.

Draw Inverse Freeform. Remove or delete a defined region from the mask. Press the left
mouse button to begin defining the region to be deleted from the existing ROI. Hold it down and
drag to define the region, and release to end or close the region. The defined pixels will be
deleted from the current mask and the VOI. A black frame appears around the icon when you are
in Draw Inverse Freeform mode, while frames around other edit and draw icons will become
white.

Draw Circle. Click with the left mouse to define the center of a circle, then drag the mouse
out to the location of the radius and release the mouse button. A circular region will be added to
the mask. The circle may be cut off if it overlaps the edge of the image.

Draw Rectangle. Click with the left mouse to define a corner of a rectangle, then drag the
mouse out to the location of the opposite corner and release the mouse button.

Pixel Searches

Connected Pixel Search. The bloodhound icon lets you “sniff out” image pixels which have
a similar value to the current pixel and are spatially connected to it. A connected-pixel search
works nicely if the structure is well-defined with crisp edges. A thresholding technique is used
which finds all pixels which have:
  a) a path of connectivity to the selected pixel, and
  b) have a value which is close to the value of the selected pixel.
The "Threshold" slider in the "BrainMaker Display Parameters" menu determines the criteria for
how close the value must be. Acceptable values must lie within a band defined by:

    (original value) +/- ((original value)*(threshold/100))

which is too say that a pixel must be within a specified percentage of the data range relative to
the current pixel. Typical threshold values to define selected structures are:

Structure        Threshold
whole brain          20
cerebellum           12
putamen              2-5

Note that the smaller the threshold value that must be to exclude unwanted pixels, the less likely
it is that this approach will work.

Delete Connected Mask Pixels. Clicking on the smashing fist icon deletes mask pixels which
are spatially connected to the current pixel in the active orthogonal view. Note that this search is

based on the mask shape, whereas the bloodhound search is based on the image values.

Histogram Search. Clicking on this icon will find all pixels which are within the thresholds
specified in the “Segmentation” menu (see that section for more details). These pixels are added
to the existing mask.



Fill a ROI. Fills interior holes by connecting the top and bottom masked pixels in every
column, then the right-most and left-most masked pixels in every row. This can result in choppy-
looking corners, but is fast and repeatable. For a more sophisticated fill, see the “Mask Filter”
section in the “Parameters” menu.

Vertical ROI Fill. Fills interior holes by connecting the top and bottom masked pixels in
every column. Since there is no right-left fill, usaeful detail can be preserved. For instance, if the
outside of the brain has been defined, using this tool will fill in the brain but preserve the
hemispheric boundaries in an axial view.

Find Edges. Clicking on this icon will find the edges of the current image and make a ROI
mask of the result. Currently, any ROI pixels in the current mask are first removed from the
mask, which is contrary to most other operations in BrainMaker. The threshold defining an
acceptable edge can be changed with the “Threshold” slider in the “Partameters” menu. A larger
threshold implies that only more abrupt edges (stronger gradient) will be included in the mask.

Mask Volume Movement

Nudge VOI. These four icons “nudge” the entire 3D Volume-of-Interest or
mask by one pixel in the indicated direction. The actual direction depends on

the currently active view. For instance, if the axial view is active, the “left” and “right” arrows
will move the mask left or right, while the “up” button will move the mask up in the axial
window, or toward the front of the brain. In the sagittal view, the “left” arrow will move the
mask left relative to the sagittal display, or in a posterior direction, while the “up” arrow moves
the mask toward the top of the brain, or in a superior direction. This sounds complicated but is
fairly intuitively obvious when you are doing it. Note that these buttons move the entire mask,
not just the single slice shown in the active view.

Flip about midline. This icon will flip the entire mask volume about the brain midline or the
central sagittal plane, so that only the x-coordinates change. This is useful if you want to

make a “mirror image” of an ROI you have drawn in one hemisphere and apply it to the opposite
hemisphere.

Image Volume Flip
The following icons flip the image volume about one of the central planes. This is one of the
operations in BrainMaker that alters the image volume, as opposed to the mask volume. If you
flip the image volume and then attempt to load a new volume or quit, you will be prompted to
save the image volume to a new file. You should select “Yes” if you have drawn and saved ROIs
using the flipped data, unless  the flip was a simple left-right flip. You can check the current
status by passing the cursor over the icons; you will see the message, “Unflip image …” in the
icon message window. A PET image, if loaded, will be flipped/unflipped as well.

Flip MRI image left-to-right, or about the central sagittal plane.

Flip MRI image front-to-back, or about the central coronal plane.

Flip MRI image top-to-bottom, or about the central axial plane.



Current View Indicators
The current view determines how mask edits are made. Clicking or drawing in any one of the
three orthogonal views (axial , coronal, sagittal) causes that view to be the currently active view.
You can also force a particular view to be active without clicking in it by clicking on its icon
(shown below). One of the three icons will be of a filled brain image, which indicates the
currently active view. If you want to see a view which is currently hidden, clicking on its icon
will cause it to be displayed in the foreground. The contents of the adjunct view are determined
by the currently active view.

Axial View. The empty icon on the right indicates the axial image is NOT currently
active, and the filled icon on the left indicates the axial image IS currently active.

Coronal View. The empty icon on the right indicates the coronal image is NOT
currently active, and the filled icon on the left indicates the coronal image IS currently
active.

Sagittal View. The empty icon on the right indicates the sagittal image is NOT
currently active, and the filled icon on the left indicates the sagittal image IS currently
active.

Adjunct view. This view is never considered to be “active”, but this button is how you request to
display the adjunct view.

Mask Display
Mask toggle: The left mask represents the 3 orthogonal views, the right mask represents the

adjunct view. The mask can be displayed as an outline (default), solid fill, or none. Pressing the
icon moves you through a series of 6 or 7 display combinations. New choices don't take effect
until a new display is requested. For outline mode, the lines are OUTSIDE of the ROI, which
means the entire ROI is visible inside the outline. The most reliable way to see a mask is in "Fill"
mode. One handy thing about this feature is that you can have the ROI appear as a filled region
in the adjunct view for reliable viewing, and as an outline in the current view so you can see the
underlying anatomy.

Blank Mask. Depress this button to temporarily remove the mask from image, and release
the mouse button to restore the mask’s visibility. This is handy if you want to take a glance at the
image underlying the mask.

Refresh mask: sets the entire working mask to 0. Do not use this feature if you intend to
save your work later- it will be gone and you will have to start over. However, in early

stages of drawing it is very convenient. This is also the way to remove a current working mask
prior to extracting or drawing a new mask.

Cut: Deletes mask from current view only, and places a copy of it in a "clipboard" in
memory. The masks from the non-current views are also stored in a “clipboard”, replacing

any masks that may have been stored there through previous cut or copy operations.

Copy: Copies masks from all three views, and places a copy of them in a "clipboard" in
memory, replacing any masks that may have been stored there through previous cut or copy

operations.



Paste: Overlays clipboard contents for current view onto the current image. The VOI is
updated to reflect this change. If the current view already contains some masked pixels, the

paste operation does not remove them, but rather adds new pixels to the mask.

Note that there is not an “Undo” button. There are several approaches to undoing mistakes, but
there is no explicit button to return you to the previous step (undo) if you are unhappy with a
change. This will be included in the next generation of BrainMaker.



III.B. Display Options Menu
This menu controls many of the display options such as cursor size/color, ROI color and style, etc.
A picture of this menu is shown below, and each menu item is explained in order of appearance.

Adjunct view. Toggle between displaying the MRI or a
PET volume (if loaded) in the adjunct window. The
default is to display the MRI image.

Color Table. Modify the color table of the images. It is
important to use this button from within BrainMaker.
If you modify the color table from other modules, the
colors of the ROI, crosshair, and cursor will not be
properly displayed.

Smooth or Sample. Determines how images are
displayed, especially with magnification factors
greater than 1. “Sample” (the default) uses a nearest-
neighbor scheme that preserves the pixelation and is a
more honest way of viewing most data. “Smooth”
causes a bilinear interpolation to be used that smooths
the data, leading to an occasionally more pleasing
appearance. “Sample” is the faster of the two display
modes.

BluRed. Sets a special set of color tables, a blue-scale
for the main display windows (which looks nice for
MRI images) and a red hot-metal scheme in the
adjunct window (which looks nice with PET data).
This is mostly for jazzy display purposes.

Crosshair: Small. You can select from 4 different
crosshair styles as follows:
  “None”: No crosshair is displayed.
  “Small”: Small bars are displayed near the edges.

  “Med”: Open crosshairs , which gives a
good view of the image point of interest.

 “Large”: Full Crosshairs, which give pinpoint
accuracy.

The “Med” and “Large” crosshairs are positioned in
the approximate center of the current pixel for all
magnifications.
Crosshair: yellow. Select from seven (7) different
colors for the crosshair, which lets you see the
crosshairs against almost any image color scheme.



Crosshair examples:

         Small       Medium           Large

ROI style: outline. Toggle between showing the ROI as an outline or as a filled volume. The filled
volume is slightly faster to display, and for ROIs with complex or raggedy edges can be less
confusing. The outline style (default) gives the best view of the image underneath the ROI for most
cases.

Opacity Controls the opacitu of a filled ROI. Low values mean the ROI will be nearly transparent.
Higher values up to 99 will make the ROI be more opaque. A value of 100 will cause the ROI to be
completely opaque, obscuring the underlying image. Different values work better depending on the
color-table and ROI color selected.

ROI: red. Select from seven (7) different colors for the ROI, which lets you see the ROI against
almost any image color scheme.

Following are some examples of outlined and filled ROIs.An ROI was drawn over the entire left-
hand side of the brain in the images below.

Outline        Filled,Opacity=30   Filled, Opacity=95     Filled, Opacity=100



Mask Filter. There are a series of so-called morphological operations that Fill or Open  a mask. In the
"Parameters" menu click on the "Mask Filter" pull-down menu. Selecting any of the options (except
"None") will cause the current orthogonal view's mask to be altered. You are NOT settig a flag for
future action, but by selecting any of the menu options other than “None”, you will effect a change
on the ROI in the currently active view. The first four operations (Dilate, Erode, Fill, Open) use the
"dim" parameter; mask elements the same size or smaller then "dim" will change.
- Dilate makes a mask bigger and fills in holes.
- Erode makes a mask smaller and removes isolated islands.
- Fill generally leaves a mask the same size but fills in holes and connects islands.
- Open generally leaves a mask the same size but removes isolated islands
   and breaks isthmuses (isthmi ?).
These are very powerful operators, especially when used in series. You may want to experiment
with these operators on some “practice” ROIs before you test them out at the tag end of a long
editing session.

There are several other related operators that affect the mask in this menu. It is especially
recommended that you play with these prior to trying them out on a hard-won VOI mask.
- Skeleton creates a skeletonized version of your mask, replacing the current ROI.
- Edge finds the edges of the mask (not the image) and replaces the current ROI mask with a group
of pixels showing the edges.

dim: This controls the dimension of the morphological operators (Dilate, Erode, Fill, Open). These
operators work with a small square-shaped “kernal” that gets moved over the images. Mask
elements the same size or smaller than the size of the kernal will be affected. The value of “dim”
reflects the size of the kernal in pixels.



III.C. Segmentation Menu
The segmentation menu contains most of the functionality for segmenting pixels into different
tissue types. Separate “Help” manuals for BrainStripper (to remove skull, scalp, etc.) and the
CerebellumStripper can be found at the SPAMALIZE web-site under the “BrainStripper” menu.

The top portion of the menu shows a histogram of the entire MRI volume that is currently loaded.
The histogram is divided into several sections showing the range of values for the common brain
tissue types: cerebral-spinal fluid (CSF), Gray Matter (GM), and White Matter (WM). The region
below or to the the left of the CSF is background, typically air (we hope!) outside of the brain. The
region above or to the right of the WM region labeled “Top” is comprised of liquid (such as blood
vessels), and other non-brain tissue.

The small middle menu-box controls which tissue types are accepted into the ROIs you draw. The
next menu contains a number of processing tools. Clicking on the “Smooth” label produces a pull-
down menu with a half-dozen processing options.



Menu Options:
This section explains each of the menu options, in order from the top of the menu to the bottom.
However, the “Filter” menus (labeled “Smooth” in the menu pictured above) are explained last.

Histogram of Image: Volume. Toggle between showing a histogram of the entire MRI volume, or of
just the current slice.

Log-plot. Toggle between a logarithmic-based plot (default) or a standard plot. Since the histogram
bins containing background pixels are usually 10 to 100 times higher than the actual brainy pixels,
the plot will not be very informative if you do not have it be log-based.

Show band. Toggle to show the plot with a colored band representing the image color at each value
(the default) or no band. The band is handy because it lets you estimate an appropriate threshold
level by eye, since you can select a color in the histogram that corresponds to a visual break
between two tissue types in the images.

Refresh. Creates a new histogram based on the current conditions. You may occasionally suspect
that the histogram does not relect the MRI image you have loaded or the current thresholds.
Clicking on this button will positively update the histogram to current conditions.

Color-Table from Thresholds: Check this box to display a special color scale for each tissue type. CSF
will get a range of deep blues, GM will get a range of bluish grays, and WM will get a range of
pinkish grays. This allows you to see tissue boundaries in the images while still retaining the
structural information you need to draw a ROI, as in the picture on the lower left. (The tissue
boundaries are ill-defined in these images.)

Show segmented image: Check this box to have the adjunct image display the current MRI image in
a few different solid colors, with one color for each tissue type, as in the picture on the lower right.
The tissue boundaries are based on the histogram thresholds, which are ill-defined for these images,
but you can still get an idea of how the various color-schemes work.

Color-Table from Thresholds     Standard Color Table Segmented adjunct image



Tissue boundary thresholds:
The threshold markers indicate where you would like BrainMaker to think that there is a hard-and-
fast boundary between two tissue types. There is not really a single value above which all values
are e.g. WM and below which all values are GM and CSF. Due to partial-volume effects, scanner
inhomogeneities, image noise, and the inherent finite resolution of a voxel-based image, there is a
range of pixel values which contain both GM and WM. With a single T1-weighted MRI image, it
can be difficult to tell what tissusue type corresponds to a given voxel if it is in this middle range.
Bear in mind that there is nothing magic about the thresholds; you set them based on your best
guess, and then we let the voxels fall where they may.

Having said that, the histogram-based thresholds provide a surprisingly powerful approach to
segmenting tissue types and providing additional visual information for drawing ROIs. The key is
to set the thresholds appropriately for the task at hand. Different tasks will require somewhat
different thresholds, depending on the goal. For instance, to draw a ROI on GM using the automatic
tissue-limiting feature of BrainMaker, you would probably want a fairly generous (i.e. wide) GM
segment. On the other hand, if you are using the cerebellar stripper, you will want wide WM and
CSF segments and a subsequent narrow GM segment.

There are several ways to change the values of the thresholds that separate tissue boundaries. You
can click on the histogram at the desired x-axis location using a different mouse buttton for each
threshold:
- left mouse button:CSF/GM
- middle mouse button:GM/WM
- right mouse button:WM/Top.
On some computers, not all of the mouse buttons are functional. You can also type a number into
any of the text-boxes below the histogram (press the “Return” key!), or click on the text-box arrows
to change any of the thresholds by a value of 1.0.

The thresholds are in units of percentage of the total range (max-min) of the MRI image values.
The threshold values thus range from 0.0-100.0. The thresholds must be in a fixed order, e.g. the
CSF/GM threshold must be less than the GM/WM threshold.

For many of our MRI data, an associated text-file exists which contains previously determined
thresholds. If this file exists, BrainStripper will automatically read and assign these threshold
values. Otherwise, you have to set the thresholds manually. By selecting the button “Set Histogram
Thresholds -> Automated”, BrainStripper will do its best to select the thresholds based on the shape
of the histogram and a few guidelines.



Tissue-limited ROIs:
By selecting and/or deselecting the various tissue regions next to the label "Accept ROIs from:", the
ROIs you draw will automatically only include pixels whose values fall within the desired tissue
boundaries, as defined in the histogram at the top of the menu. This magic ensues because a
reference ROI mask is created if BrainMaker senses that not all of the tissue types are desired. This
reference is compared to all ROIs subsequently drawn, and undesired tissue types are excluded
from the ROI before it is displayed. You can draw a big, sloppy ROI as shown below on the left,
and the undesired tissue (in this case, all but GM) will automatically be removed.

Original sloppy ROI. Automatically segmented GM ROI.

To take advantage of this feature, you must first select/unselect the tissue types you want to
include/exclude. If a box is checked in the "Accept ROIs from" menu, that tissue type will be
included. The default is to include all tissue types, as in the menu shown below. This feature
requires a fair amount of memory and computation overhead, so if you do not need it, you should
leave all of the tissue types selected.

Click on the “All” button to select all of the tissue types in one stroke. Click on the “Verify” Button
to see a list of the tissue types that BrainMaker thinks you have selected. (This list should match the
checked boxes.)

If you want to play with the thresholds to see how they affect an ROI that you have drawn, you can
click on the "Hold VOI" button. This will store the current ROI volume mask, so that you can move
the thresholds up and down and still recover your original ROI. The button will read “VOI Held” and
the box will be checked, to remind you that this feature is active. Otherwise, if you set a stringent
threshold you will be unable to later recover areas that were automatically removed. The data and
time are printed in SPAMALIZE’s message window, so you can check when you saved a VOI.



Click "Apply 3D" whenever you want to apply the current threshold settings to your original ROI.
All planes in the current orthogonal view containing the original ROI will be examined and
displayed, so unless you have a compelling reason otherwise, it is best to select the view with the
fewest number of planes containing the ROI. If you are not sure, select the axial icon, since
usually the pixels are thickest in the z-dimension. If "Hold VOI" is unselected, the threshold settings
will be applied to the current working VOI mask, with the result that it will shrink in size every
time you select a more stringent thresholds; conversely, with "Hold VOI" unselected, you cannot
increase the size of the VOI by setting more lenient thresholds, since there is no reference for pixels
to add back.
Sound confusing? Yup, this feature is a kluge on top of a kluge. If you follow these instructions
carefully, you will find this a handy feature. You will definitely want to practice with some scrap
data before you try this feature on your prize VOI the night before the abstract is due.

Changing the histogram threshold values in the histogram in the "ROI stats" menu has the same
effect as clicking "Apply 3D", so you can change the thresholds by looking only at the ROI's
histogram and save some menu searching.

Turn off the tissue-limiting behavior by selecting all tissue types. You can now add freely to the
current mask, although your original mask will be lost. To restore the original VOI you had when
you first clicked “Hold VOI", select "All" (indicating you want all tissue types), and then click "Apply

3D" to recover the original VOI. Now select the checked button, "VOI Held" to return to "Hold VOI".
You will get a warning message about saving your original VOI whenever you turn off "VOI Held".

1 23



Bottom Button-Menu:
Lop Top. Lops off all values above the “WM/Top” threshold, and sets these pixels to the value of
the “WM/Top” threshold. For most “raw” MRI image volumes, a very small fraction of the pixels
occupy a very large fraction of the value range (“bandwidth”). These pixels usually correspond to
blood and other non-brain residue. Since they occupy most of the bandwidth, they also hog most of
the available colors, making it difficult to see the brain tissue you are really interested in with an
acceptable contrast.
In the histogram below from a T1-weighted MRI image, the CSF, GM and WM tissue values are
confined to the peak at the left; the pixels to the right of this peak contain mostly blood. Since the
histogram is plotted on a log-based scale, it is apparent that a small fraction of the pixels (< 1%)
occupy most of the pixel values (from ~200 – 1250). The resulting images look like the coronal
image below.

Changing the color table range only helps slightly. You can compress the color table so that top
color (white) reaches down to a value of 200, but this results in a loss of contrast since a range of
data values (say from 180-186) get compressed into a single color bin. A better solution is to “lop”
the useless top values off, enabling you to get the full benefit of the data’s useful range.

Move the “WM/Top” threshold to a position somewhat to the right of the WM peak, indicated by
the dotted purple line. You may have to move the “”CSF/GM” threshold (and others) below this
point first. Then click on “Lop Top”. All values above the “WM/Top” threshold (in this case 195)
will be set to that value (195). Then, the entire MRI image volume will be scaled to a range of 0-
255, and converted to an 8-bit (BYTE) image. If the maximum value you want is near 255, then
you can simply select “Lop Top 255” to avoid setting the threshold to 255 explicitly.

The new histogram and image for the rescaled data should appear as shown below. The threshold
values will still have their “old” low percentage values, so you will need to reset them as has been
done below. Note the greatly improved contrast (and more noise) in the new MRI image.



Histogram-Eq CT. Applies a histogram-equalization to the current color table, frequently resulting in
better contrast as sown below. You can undo this effect by re-clicking on the button.

Original Image Histogram-Equalized Image

Write: Clicking on this button creates a pulldown menu with several options for writing various
image volumes to a file in the SPAMALIZE “temp” directory (at the LfAN, this is “/scratch/”).

- Current MRI. Writes the contents of the current MRI volume you are using. This lets you make
changes to the MRI volume (like “Lop Top”) and then save the changed data to a new file that you
can use for subsequent analysis. The file will be named similarly to the original file, but with a
date/time-stamp. If you don’t have write-permission for the directory where the original file lives,
the new file will go to “/scratch/”.

- Whole Brain Mask. Writes a bit-map of the current VOI working mask to an ANALYZE file. All
masked voxels will get the value “1”, all unmasked voxels will be labeled as “0”.

- Segmented Mask. Writes a segmented mask to an ANALYZE file. Different tissue types get
different values. The tissue types are segmented according to the current thresholds. BrainMaker
knows how to recognize these various tissue types in an ROI file.

CSF/GM/WM. Creates segmented image masks showing how the tissue in the current image is
divided according to the current thresholds, as shown below.

CSF GM WM Original Image

You can display the axial, coronal, or sagittal image depending on which is currently active. Each
time you change a threshold, you need to click on “CSF/GM/WM” to see the new segmentation. This
feature is very helpful for setting up all of the BrainMaker applications that use the histogram
thresholds.



Filter Option Menus.
There are a number of sub-menus available to let you try various filtering options and segmentation
techniques. Clicking on the button labeled “Smooth” in the Segmentation menu makes a dropdown
menu from which you can select a sub-menu. These include:

- Smooth
- Sharp Smooth
- Edge Find
- Sharpen
- Watershed
- Find Brain
- Find Cerebellum
- Clean

Some of these are menus for full-fledged applications (like “Sharp Smooth”, “Find Brain” and “Find

Cerebellum”). Others are more experimental in nature (like “Watershed”), and let you apply specific
filters to your data on a trial basis. If you like what it does, ask Terry to implement the filter for the
entire image volume so you can save your data. Following is a description of each menu.

Smooth. Applies a smoothing filter.

Select either “Boxcar” or “Median”. Then click on the other “Smooth” button to get a dropdown
menu pf choices. You can apply the smoothing filter to either the current image, to see what the
result looks like, or if you like the result, to the entire image volume. The Numbers that appear in
the drop-down menu refer to the size of the smoothing filter kernal, in pixels. You can choose from
various kernal sizes, from 3x3 to 9x9. Larger kernals yield more smoothing.

The images below show the result of applying a 5x5 boxcar and median filter to a sagittal image.
The median smooth is better at removing “salt-and-pepper” noise, and also is better at preserving
edges. The boxcar approach is better at “smearing”.

Original Image Boxcar (5x5) Median (5x5)



Sharp Smooth. Applies an edge-preserving filter.
This is a magic filter that removes most “salt-and-pepper” noise while preserving edges to a
remarkable degree. This filter is a processing steps for most of the anatomic MRI data at the LfAN.
It implements an iterative method known as “anisotropic diffusion”, described by Perona & Malik
(1990), Nordstrom (1990), and Gerig et al. (1992). It uses an equation similar to that used to solve
the thermodynamic problem of anisotropic diffusion of heat in a solid. The idea is that the
algorithm examines the 2D or 3D gradients of the image, and uses this information both to dermine
what regions should be smoothed together, and where boundaries are that should not be smoothed.
It is a delighfully elegant algorithm, and it works amazingly well.

The only downside is it is computaionally intensive. It takes about 30 minutes to run on a fast
computer, and it needs approximately 500 MBytes of RAM to avoid memory swapping for a
256x256x128 data set. Do not try this on a slow or memory-limited computer!

The menu is simple, but it can be time-consuming to find the right combination of the three
parameters for a given image. For 99% of the T1-weighted MRI images at the LfAN, the
parameters below work well. It took quite a while to home in on these parameters, however, but be
patient- the results are worth it!

The “2D” button will work on the current image only, to give you an idea of what will happen if
you apply these parameters to the entire image volume by selecting “3D”. The 2D version takes
about 20 seconds to complete, so you can easily get a preview before you commit to the longer 3D
version. Clicking on “3D” means you should go for lunch, because this algorithm will take over
your computer. When it finishes, BrainMaker will replace the current MRI with the new smoothed
version, and then will write out the new smoothed volume to an ANALYZE file in the same
directory as the original file, if possible. If for some the write fails (e.g. because the disk is full),
you can make room on the “temp” disk (“/scratch/”), then write the image there using the button
“Segmentation -> Write -> Current MRI”.

“Iterations” refers to how many times the algorithm will repeat itself. The first iteration produces a
slightly smoothed version of the original image; subsequent iterations work with the preceeding
smoothed image. More iterations take longer and smooth more.

“Weight” controls what fraction of each smoothed image is added back into the original image
before feeding it to the next iteration. Larger weights add a higher proportion of the smoothed
image back into the original image.

“Diffusion Strength” determines how much each iteration will smooth. Higher values imply more
smoothing. This parameter is non-linear, so there seems to be more sensitivity in the range from 10-
30 than below or above these values.

The best results are obtained by using many iterations, a low weight, and a low diffusion strength,
so there is a small change for each iteration. However, using 60 iterations and correspondingly



smaller weight and diffusion strength parameters will not make the results twice as good; 30
iterations yields quite nice results for typical MRI data. The images below show how most of the
“salt-and-pepper” noise has been removed. This is most obvious in the large WM region. However,
notice how much better the edges are preserved compared to a median-filter smooth. The edges are
almost perfectly preserved, and only the smallest structural elements (similar in size to noise
elements, or 1-2 pixels) have been removed.

Edge Find. Finds edges of the current image. This is an experimental module that doesn’t do
anything useful except display the edges. Select one of the smoothing options to produce fewer but
more connected lines. Click on “Edge Det” to see the result. The edges are also displayed
superimposed on the original images, as shown at the bottom.

No Smoothing (above), Median (below) Boxcar (above and below)



Sharpen. Applies various sharpening filters to the current image, for display only.

The “Roberts” and “Sobel” filters are standard sharpening filters based on local gradients. The
“FFT” option removes lower-frequency data, leaving behind higher-frequency data that tends to
emphasize smaller details, including image noise. A larger value for “FFT Filter” produces less
filtering and clearer images for the FFT options.

The “FFT 3D” button applies a 3D FFT filter, and replaces the current MRI volume with the filtered
volume. This option, while fun to play with, does not usually succeed in making the image usefully
more sharp before the noise component becomes overwhelming. Shown below is the best
compromise between reasonable sharpening and accepatble noise; the result here does not add
much information beyond the original image, but this might be useful in another application.

Original FFT sharpened (alpha=76)

Watershed. is an experimental module (read, it doesn’t do anything useful and looks obviously
unfinished) that segments images using the watershed algorithm. This is a really cool algorithm
whose downside is that it tends to over-segment, leaving you with too many segments for what you
would like to be a homogenous chunk of tissue. Watch this space…

Find Brain. Segments the Whole Brain, stripping away skull, meninges, eyes, tongue, etc. It works
quite nicely, and is a good choice if you don’t want to coregister your data to a template, and/or if
you only have a single T1-weighted MRI (i.e. no multi-spectral data).
A complete help manual for this program can be found at the SPAMALIZE web-site under the
major heading “BrainStripper”. This routine is designed to strip away non-brain pixels outside of
the brain itself. It tends to err on the side of including all of the brain, at the expense of also
including some non-brain pixels. This balance can be easily shifted by editing the program.

Find Cerebellum. Similar to “Find Brain“(above) in functionality and location of instructions.

Clean. Removes small isolated “islands” from an image or a mask.



III.D. Anatomy Menu
Select the "Anatomy" button from BrainMaker's main menu. The resulting pop-up menu provides
facilities to name the current ROI, display a specific ROI stored in a file, write a ROI to the file, or
delete a ROI from the file. This routine is independent of BrainMaker, but is closely linked to
BrainMaker as well as other programs such as BrainSpinner, providing a common approach to ROI
definition and analysis throughout SPAMALIZE.

There are currently ~30 named anatomic regions defined, such as “Whole_brain” and “Cerebellum”
in the menu shown above. Additional regions may be defined by editing the file
SPAM_ANAT_DEF.PRO, which contains instructions for adding a new region. This menu contains its
own "Help" menu, most of which is repeated below.

There are three different mask volumes you need to know about to take advantage of the VOI
features in BrainMaker:

1) Current working volume: Contains a single (VOI), which is the volume you create and edit in
    the  view-windows. The 2D ROIs always display slices of the current working volume.

2) Group volume: Contains one or more distinct VOIs. The Group volume exists in memory (not
   on disk) and is a container for individual VOIs. The Group volume acts as the intermediary
   between the working volume and the saved volume in a file on disk.

3) ROI mask file: A semi-permanent version of the Group volume. It is on disk so it is more or
   less permanent, but since you can update or even overwrite the contents I call it "semi"-
   permanent.You should save the Group volume to the ROI mask file when you are done editing,
   or during an editing session if you have a feeling of impending doom.



The three mask-volumes mentioned above can be accessed through the following respective menus,
described in some detail below. Most of these buttons are described in even greater detail elsewhere
in this manual.

ROI-File
-> Create New File: Creates a new ROI file, and loads the new empty file into the Group mask
volume. The filename will be based on the MRI file by default, but you can also edit the filename if
you wish. The contents of the existing Group mask volume, if any, are erased, but the current
Working mask volume is unaffected.

-> Find File:  Finds a ROI mask file and transfers the contents into the Group volume. The contents
of the existing Group mask volume, if any, are erased, but the current Working mask volume is
unaffected.

-> Save ROIs to File: Saves the contents of the current Group mask volume (stored in memory) to a
file stored on disk. All of the constituent VOIs in the group are saved in a single ANALYZE 3D
volume that has the same size and pixel dimensions as the currently loaded MRI file. This action is
identical to what happens if you select “ROI- Group -> Save ROIs to File”.

-> Delete Selected ROIs:  Deletes a selected ROI from the Group mask volume and also from the
associated mask file. Select a single named anatomic structure from the list of currently available
names prior to deleting. Detailed instructions are given in another section of this manual. This
action is identical to what happens if you select “ROI- Group -> Delete Selected ROIs”.

-> Compare 2 Masks: This button toggles BrainMaker between its normal “edit” state, and a special
“view-only” state that lets you read in a second VOI and superimpose it over the currently loaded
VOI. Editing is disabled because Brainmaker is unable to effect changes to the original working
mask when a second mask is loaded. After clicking this button, you should browse for and load the
second mask file just as you did the first one, then extract the desired anatomic structures from the
resulting Group volume. To return to “edit” mode, select “ROI-File -> Compare 2 Masks“.

ROI-Current
-> Store ROI to Group:  Moves the the contents of the working mask volume into the Group mask
volume in memory and stores it as whatever structure is currenty indicated in the “Anatomy” menu.
This does NOT save your work to disk! Select a single named anatomic structure from the list of
currently available names prior to storing.

-> Extract ROI from Group:  Move a ROI from the Group mask volume to the current working
volume. This will not erase or replace the VOI in the working mask you may have been editing, but
rather will add to it; the resulting VOI will be the union of the current working VOI and the new
extracted anatomic structure’s VOI. Select a single named anatomic structure from the list of
currently available names prior to extracting.

-> Save bitmask: Saves the current working VOI as a simple 8-bit ANALYZE volume to disk. The
current elements of the VOI have a value of 1, while all unmasked pixels have a value of 0. This is
handy if you want to use your VOI as a mask with other programs such as AIR, SPM, or AFNI.



ROI-Group
-> Save ROIs to File: Saves the contents of the current Group mask volume (stored in memory) to a
file stored on disk. This will overwrite (erase) the current contents of this file (it is normally OK to
do this).All of the constituent VOIs in the group are saved in a single ANALYZE 3D volume that
has the same size and pixel dimensions as the currently loaded MRI file. This action is identical to
what happens if you select “ROI- File -> Save ROIs to File”.

-> Examine All: Displays the ROI masks in the current plane. Frequently ROIs with a low storage
value will have a color that is indistinguishible from the background.

-> Delete Selected ROIs:  Deletes a selected ROI from the Group mask volume and also from the
associated mask file. Select a single named anatomic structure from the list of currently available
names prior to deleting. Detailed instructions are given in another section of this manual. This
action is identical to what happens if you select “ROI- File -> Delete Selected ROIs”.

-> Search Group for ROIs: Searches the current Group volume for any values recognizeable as a
valid anatomic VOI, as defined in SPAM_ANAT_DEF.PRO. Although you normally don’t need to use
this feature (since it is invoked automatically when reading a file) it can be handy in case you
suspect that, due to some tricky combination of processing events, BrainMaker has “forgotten” or
ignored an anatomic structure that you think should be in the current Group. If pressing this button
fails to find your structure, there is no recourse- it is gone!

You can add additional anatomic labels to the list by clicking on “Add ROI to List”. A pull-down
menu will appear listing all of the anatomic VOI names that BrainMaker knows about. Select one
of these to add it to the visible list of potentially active VOIs. Then, you may save a new ROI with
this new anatomic structure’s name

The next few sections give details about managing your VOIs, including how to create a new VOI
file or load an existing file, and how to extract and save current and group VOIs, and how to delete
an individual named VOI from an existing group VOI.



Create ROI Mask
1) Current working volume: Contains a single (VOI), which is the volume you create and edit in
the view-windows. The 2D ROIs always display slices of the current working volume.
2) Group volume: Contains one or more distinct VOIs. The Group volume exists in memory (not
on disk) and is a container for individual VOIs. The Group volume acts as the intermediary
between the working volume and the saved volume in a file on disk.
3) ROI mask file: A semi-permanent version of the Group volume. It is on disk so it is more or less
permanent, but since you can update or even overwrite the contents I call it "semi"-permanent. You
should save the Group volume to the ROI mask file when you are done editing, or during an editing
session if you have a feeling of impending doom.

You must create a mask-file before you can save the ROIs you will draw. However, you may add
ROIs to a previously existing mask-file (i.e. one that you created in a previous session).

To create a new mask-file, select "ROI- File -> Create File". The default naming convention is to add
"ROImask" to the reference filename. For example, if you have a file named

W:\exp\morhip\MRI\sub123\E123.img
the ROI mask file would be named something like:

W:\exp\morhip\MRI\sub123\E123_ROImask.img
BrainMaker checks to see if a file with the currently selected name already exists, and gives you the
option to overwrite it (which you should only do if you are SURE you know what you are doing) or
else to create a new filename with a date/time stamp incorporated, e.g.:

W:\exp\morhip\MRI\sub123\E123_ROImask_20000413_112845.img
where the numgers show the year (2000), month (04), date (13), hour (11), minute (28), and second
(45). If you follow this naming convention then subsequent searches and data processing will be
facilitated. You must have write-permission or the disk (folder) where you wish to store the new
mask-file. An ANALYZE file with the identical dimensions as the reference file (MRI) will be
created so there must be room on the disk, or else the write will fail.

Find/Load ROI Mask
To load an existing mask-file select "ROI- File -> Find File". There is some error-checking to ensure
that the mask-file has the same dimensions as the currently loaded reference file (as described in
the associated .hdr file). Different pixel-dimensions are allowed, since frequently this information
is missing or wrong.

It is up to you to ensure that the mask-file is somehow related to the reference file, and also that any
coregistered images are related (i.e. from the same subject). In particular, BrainMaker does NOT
check to see that image-volumes are from the same subject. This provides maximal flexibility, but
also requires you to take some responsibility for your data.



Store ROI
There are four steps to saving a mask for a region:
1) Create the working mask volume.
2) Select a name for the masked region from the Anatomy menu.
3) Store the working mask volume to the group mask volume (in memory).
4) Write the group mask volume to the mask-file.

Step (1) is reviewed in other Help menus. The most important step here is to define what the region
will be called, which in turn determines how it is stored.

To select a name, simply select an item from the Anatomy menu. You may select either "Right",
"Left", or "Both" for any named structure. To unselect a structure, select the "None" button, or the
"Unselect All" to unselect all structures, which is handy if you have a long list of structures that are
not all visible in the menu. When all structures are unselected, select the single structure you wish
to write. You may only store a mask for a single structure at a time. If more than one structure is
selected, BrainMaker will refuse to store anything, and will print a message to the screen informing
you of the nature of the conflict.

If you draw a region and store the mask, then draw another region without selecting a new mask-
name, you will create the union of the two regions, with the label of the first region. This can be
helpful at times (e.g. to create a mask composed of isolated islands of tissue) but is generally
regarded as a mistake. You will be unable to separate the mask into its Right and Left components.

If the new ROI includes pixels previously drawn in another ROI, these pixels will no longer belong
to the old ROI. The pixels will not be lost to the old ROI if  the new ROI is a child (subset) of the
old ROI. For instance, most regions are subsets of "whole_brain" and "left_brain" or "right_brain".

Every structure defined in the Anatomy menu has a unique integer value associated with it. (To
determine the actual values, see the comments in SPAM_ANAT_DEF.PRO). Furthermore, left-side
structures have positive values, and right-side structures have negative values. Searches for an
entire structure can easily be performed by looking for the absolute value of the desired structures
value.

Nested structures can be accommodated. For example, the caudate and the putamen constitute the
striatum. The cuadate has a value of "51", the putamen has a valueof "52". The structure defined by
"striatum" contains the subgroups "caudate" and "putamen", so values of "51" and "52" correspond
to the striatum. Note that although the striatum has a value of "50", this value is never stored. The
user should only write masks for atomic structures.

Move the working VOI into the Group VOI by selecting “ROI  -Current -> Store ROI to Group”. This
puts your working VOI into the hierarchical structure of a BrainMaker VOI file.

To permanently save your work, you must write it to a file. First you must create a new ROI file, or
load an existing one (reviewed elsewhere). Selecting "ROI  -Group -> Save ROIs to File" will save
your work. This will cause the current contents of the reference ROI mask volume (in memory) to
be written out to the file named in the Anatomy menu. Note that this will overwrite the existing



contents (if any) of this file.You can avoid this by renaming the file in the Anatomy window. For
example, rename
"/data2/p123_ROImask.img" to
"/data2/p123_ROImask_new.img".

The working ROI volume will persist in memory until:
  - you delete it using the icon.
  - you load in a new ROI mask file;
  - you quit BrainMaker;
  - SPAMALIZE crashes.

Delete ROI
Deleting a region from a mask-file is a three-part process:
1) Select the region you wish to delete from the mask-file.
2) Determine what to name the ensuing "hole" created in the mask-file.
3) Delete the region.

The major issue in deleting a region is that it may overlay another region. For instance, most
structures lie within the larger region "Whole_brain". The procedure used by this program allows
the user to specify any region, including "Undefined", to replace the void created when a region is
deleted. Usually you will want to select either “Whole_brain” (which has a value of 1) or
“Undefined”, which has a value of 0.

Select "ROI- Group -> Delete Selected ROIs" from the Anatomy menu. A special menu appears with a
window. Move the cursor over the image until the desired structure name appears in the text-box.
Follow the printed instructions (click the mouse button) to select the structure you wish to fill in the
void which will be created when the current region is deleted. To fill with a region which does not
exist (because you have not drawn it) you can type in the name of a valid region as defined in
SPAM_ANAT_DEF.PRO. This is for advanced users only! You may also select (or type) "Undefined".

You must "Quit" from the delete menu before proceeding to draw another ROI.



III.E. Analysis Menu
Clicking on the “Analysis” button in BrainMaker’s main menu produces a pull-down menu with a
number of analysis options. The underlying programs tend to have been written for a single
purpose. All of these programs have worked (and worked well) in the past. If you experience
difficulties, notify Terry Oakes; it will probably take only a minor tweak to fix things.

Ghost Removal
This program was designed to remove "Ghost artifacts" from a MRI image volume, but is fairly
general-purpose. It will set all pixels in a group of axial planes to 0.

To select a group of planes, move within BrainMaker to the first (last) axial plane you want to
set to 0. All planes between this plane and the top (bottom) of the image volume will be set to 0.
This is useful to facilitate connected pixel searches, and also to remove ghost-artifacts prior to
using a coregistration package such as AIR.

If you are above the middle plane, all planes from the current to the top plane will be set to 0. If
you are below the middle plane, all planes from the first to the current plane will be set to 0.

The result will be written to a file named something like:
/full_path/mri_filename_ug.im
The "_ug" suffix stands for "unghosted".

Each time you set a block of planes to 0, a new file is written. However, the same file-naming
convention is used for a given MRI file, so you can remove both top and bottom planes in
succesion, and have a single file in the end.

Coregistration Check
Under the “Analysis -> Check Coreg” menu you can find several tools to check the validty of a
coregistration attempt. The SPAMALIZE module “BrainSqueezer” is much better suited for this,
but sometimes it is handy to use these older tools. The results of these various operations depend
on the value of the “Threshold” slider in the “Parameters” menu.
"Interleave" creates an image where all even rows are PET, all odd rows are MRI, so you can see
both images together. Use a threshold value of ~60%.
"Overlay" finds the edges of structures in the MRI image, and superimposes these edges onto the
PET image. A threshold value of ~90% works well for the threshold method, a threshold value of
~0% or more usually ~30% works well for the windowed method.

Pasting a Mask onto an Image
BrainMaker only allows you to edit a single VOI mask at a time. However, occasionally it is
useful to have another mask present as a reference while you are editing the current VOI. To do
this, you simply extract (or draw) the VOI you want to use as a reference, and paste it into the
MRI image. The mask becomes a permanent part of the MRI image, until you load in a new
MRI. If you save the MRI volume now, the image of the mask will be there as well. However,
bear in mind that it will still only be an image for drawing upon, not a ROI-file that Brainmaker
will recognize.



The steps are as follows:
1) Extract the structure you want to use as a guide from an existing ROI file, or from your
current Group volume, or simply use the contents of your current working mask. In all cases, you
need to get the reference structure into the working mask volume.

2) Select “Analysis -> Combine Mask, Image -> First Addition “. The mask will be pasted into the
mask image and displayed in a hot-metal color scale, as shown below. You can select any of the
“Split” color scales for image display. Initially the MRI image will be shown with a slightly
pinkish cast, to remind you that this is not the original MRI image. Note that the original ROI is
still active, as shown below in the second image from the left.

3) Delete the current working VOI . It exactly matches the orangey area that has been pasted into
the MRI image, as shown in the middle image below.

4) Load, draw and/or save your ROIs as usual. The ROI color was changed from red to green for
greater distinction in the right-hand images below. You may want to select the filled ROI option
(“Display Parameters -> ROI style -> filled”) for more precise comparison, as the outline of the ROI
in “outline” mode is actually outside of the ROI.

Original ROI.         ROI and Pasted ROI.    Pasted ROI result.          New ROI (outline).       New ROI (filled).

If you decide that you want to paste another masked region into the already altered MRI, you
must select “Analysis -> Combine Mask, Image -> Second Addition “. If you do this more than about
4 times, things will go South.

If you extract a VOI from an existing file and then want to save your new ROI to a different file,
you must first select “Anatomy -> ROI- Group -> Clear Group”. Answer “Yes” to the resulting dialog
box. Then type in the name of a new ROI file, and select “Anatomy -> ROI- File -> Create File” as
usual.




